The brake lights on my 1999 e320 do not work. THe third tail light in the rear window does. I have replaced the stop lamp switch, the driver side inner tail lamp assembly and all bulbs. All of the other tail light work with the exception of the two brake lights. What is my next step?

Comments

It is possible that you have a bad Sam module. What I would do is to get the wiring diagram for the brake lights and use a multimeter to check if there is continuity. If the wires are good then it most likely be the sam module. I am not 100% sure but for that year you may be able to install a used one.

Thank you for the suggestion. I found a diagram a couple of days ago. Will run the circuits and see what I get. I will probably have more questions in a couple of days.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.