I'm a mechanic too who just had a car towed from another shop. They diagnosed needing the balance shaft, stating it was 1200 &1208. Said it was only codes but plugged in and pulled a 1208 and many misfire codes. I was going to do the replacement shaft until I notice the cam sensor they claimed to have replaced were clearly old. But all the coil packs and plugs had been replaced, not mentioned in the order. I had the covers off and decided to check the marks. Crank on 40, alignment marks were dead on. Put it back together, start it and read the data on my Snap On Modis edge. Cam sensor on exhaust cam was flat lining. Replaced it, was reading showing on graph. The previous misfires cleared up, ran smooth. Test drove, ran fine. no CEL. Next morning plugged in Modis and code1200 had popped up. Pulled the 2 cam sensors from right head, turned the crank to 40 and the 2 numbered circles lined up perfectly to center of sensor hole.

The magnets tested good with power applied. I took the cam cover off and stuck a boreoscope camera along the t chain to see the balance shaft gear, all teeth in good shape.

Tomorrow with replace the magnets on the head. What else could cause the 1200 code?

Thanks. first picture is the balance shaft gear. second is new one. Thanks for your healp.

Comments

Profile picture for user MercedesMedic

Did you guys make any more progress on this issue? The problem is usually either Mercedes Camshaft Adjuster Solenoid Failure or Balance Shaft Failure.

Maybe you have a unique case here. I would look into issues with the wire harness to those sensors as well.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

2010 Mercedes ML350 BlueTec fuel leak (Left tank)

0
tarheel3759
5 days 22 hours ago
Mercedes » M-Class » 2006-2011

check liquid level

0
equintquant2
5 days 23 hours ago
Mercedes » C-Class » 2001-2007

Mercedes Benz clk w208 supercharger

0
timcolledge
1 week 1 day ago
Mercedes » CLK-Class » 1998-2003

Dodge. Journey 2015

1
TennesseeRebel
1 week 1 day ago
Dodge » Journey » 2009-____

Is it my ignition switch?

0
lcserna0423
1 week 1 day ago
Dodge » Caravan » 2008-____

2009 Mercedes e350 rwd 80 k miles

2
lucapuca
1 week 4 days ago
Mercedes

2006 chrysler crossfire convertible top problem

2
daisyblemmons
2 weeks ago
Chrysler » Crossfire

Problem with automatic start

4
abchris
2 weeks ago
Audi » A3 S3 RS3 » 2015-____

Mercedes ML350 bluetec sputter misfire

1
Nmerc
1 week 3 days ago
Mercedes » M-Class » 2012-____

Fuel issue

1
Andrew Williams.90
1 week 5 days ago
Buick » LeSabre » 2000-2005

Brake system

2
tammyduran
2 weeks ago
BMW » Z4 » 2003-2008

Best Shocks for Grand Cherokee

2
JohnSmith75
2 weeks 2 days ago
Jeep » Grand Cherokee

W212 AMG seat swap

1
GPone
1 week 5 days ago
Mercedes

do you need to register new battery on 2006 z4???

1
jdgallo
1 week 5 days ago
BMW » Z4 » 2003-2008

Mercedes CLA 250

4
jc71
2 weeks 1 day ago
Mercedes

CHANGING DASHBOARD LANGUAGE

2
Master
1 week 6 days ago
Volvo » S40, V40

2004 f150 wont start

1
dldiggs2
2 weeks 2 days ago
Ford » F-Series » 2004-2008

2006 chrysler crossfire convertible top problem

1
daisyblemmons
2 weeks ago
Chrysler » Crossfire » 2004-2007

Intermittent issue with low cranking power when ESC OFF light comes on

1
SteveJ27
1 week 6 days ago
Hyundai » Elantra » 2007-2010

Apple car play for 2016 e350 4matic

2
Triangle123
1 week 6 days ago
Mercedes » E-Class » 2010-2016

User has not asked any questions.