Question Details

Hi. 

My 2008 A170 wont start. It says SRS malfunction on display. Drive to nearest workshop but it won't start. Engine just makes a tick noise but no turnover whatsoever. I did check the battery which was replaced a few months ago and it says fully charged. Any idea as to what might be wrong? 

Comments

Profile picture for user MBFanatic

MBFanatic  6 months 1 week ago

Try jump starting it and let us know if it starts. 


Profile picture for user jeremy

jeremy  6 months 1 week ago

I agree you need to try jump starting the car. It sounds like a weak battery.

If not the battery, then I would check the starter.


Profile picture for user Anthonie

Anthonie  6 months 1 week ago

Not really keen on jump starting it. Heard that it might cause other issues. Gonna get a new test battery tomorrow and see if that sorts it out otherwise I'll have to get it towed to a dealer. Thanks for the advice 


Profile picture for user jeremy

jeremy  6 months 1 week ago

Airbag will not prevent the car from starting. Have you tried starting the car by connecting a 12 volt to the starter solenoind? There is a good chance your starer is bad.

The worst case would be a siezed engine. But let's hope that is not the case here.


Profile picture for user Anthonie

Anthonie  6 months 1 week ago

Thank you all for the help and suggestions. Had my car fixed today. Turned out to be the main ignition relay that was broken. Replaced it and all is fine. 


Profile picture for user MBFanatic

MBFanatic  6 months 1 week ago

Thank you for the update.