99 Mercedes Ml320 stuck in limp mode, no codes, help!

Question by wanderwoman posted 5 months ago in 1998-2005 (W163)

Okay here’s the specifics... When I bought car the instrument panel on dash never showed what gear I was in, (no light ever came on) so I was unaware that one was even supposed to come on until recently. But car ran fine, never noticed any issues with shifting accept that if I didn’t put it into 4th gear and left it in D it would pop out of gear or into a lower gear every time I jumped on the accelerator. But putting it over into 4 position eliminated that so that’s how I always drove it. Now several months later I’m with the current issue. I left sunroof open and it rained. Next morning I hopped in and drove about 3/4 of a mile to the gas station to put air in tire. It drove like normal, put it in park to air up tire and went to take off and stuck in low gear. Tried shifting other gears, nothing changed. Tried turning off and on, still stuck. Researched online and was certain it had to be the shifter due to getting wet, so I ordered another one and installed. Still no change. I’ve checked for codes and no codes other than my usual o2 sensor codes are coming up. I got underneath and pulled out the plug that also tends to be culprit due to fluid getting into seal and although there’s fluid around it, seals seemed to be still good because inside plug looked dry and clean. Also want to note that intermittently prior to this happening, the car wouldn’t always Go into P park when shifted to P position, so my key would’nt come out and car wouldn’t restart until I messed around with the shifter a few times then I’d get it to lock so key could be removed. Now however, the car is shifted into Park position, but it will shift freely to all other gears without me pressing the brake pedal first. I’ve also recently replaced the brake pedal switch and brake booster so I’m pretty sure that’s not bad. please help. Not trying to keep dumping money to trouble shoot this issue. But with no codes coming up it makes it hard to figure out why I can’t get it out of limp mode. thank you for any and all help!