Hello there.I own a MB C200 2006.I already discussed about this issue and you gave me your idea however the problem is getting worse.my car used to shift 2-3 on C mode jercky but smoothly on S mode and that was its only problem.I changed gear box oil and filter the other day unfortunately the gearbox not only became better but got worse.now after start it doesn’t shift up or down and sticks in one gear and after a 30-min driving it gets better and normal and shift smoothly.Could you give me a solution this .Thanks

Comments

My guess is that one of the valve body solenoids is sticking.

If there are no codes in the TCU, I would replace the valve body. I think your car has the 722.6 transmission. You can install a valve body from another car, no need for programing.

Also, I assume you already checked the 13 pin connector, right?

Let us know once you resolve the problem.

 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.