Hello. I have a problem with my MB Cla 220 CDI 2013y automatic transimission. When car is standing and i put it in D or R it starts to shake. I have buy in MB and changeboth motor holders but problem is still here. In N or P is better and car is not shaking so much. But when i put in D or R i feel push and car is shaking. When i start to drive car everything is ok again. Doesnt metter if car is cold or warm, all the time is shaking in D and R. What do you think what can cause this problems? 

Comments

Did you change both left and right engine mounts?

Also, you have a transmission engine mount as well. Did you change that?

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.