Question Details

Hi guys, I want to know if someone has the same problem and how to fix it. My Hyundai Santa Fe 2001 2.7 V6 has problems with the engine, the car run but after 10 min driving once car gets hot it does gargle and gives milestones until car stop but u can drive again after cold. Check engine light no on, I already tried with scanners but none code show. Can someone help me?

Comments

Profile picture for user MercedesMedic

MercedesMedic  2 months 2 weeks ago

The first thing that comes to mind is the mass air flow sensor. When it fails it can act up when engine is hot. 

But that's only a guess. Where did you read the codes? I would suggest either go to a different place or try  a different OBD-II scanner. Some scanners have issues connecting to certain models. 


Profile picture for user allanbung

allanbung  2 months 2 weeks ago

I will check that sensor. I readed the codes with my two modern scanners and autozone place, the firsts times check engine and codes show up but now even with switch on check engine light dont show. Autozone place told me probably computer locked or maybe injectors because they think fuel problems, now I'm going test those injectors. I appreciate ur answer!


Profile picture for user MercedesMedic

MercedesMedic  2 months 2 weeks ago

What were the codes that showed up in the first place ? 


Profile picture for user abusufyan

abusufyan  2 months 2 weeks ago

I know it has been a while, but were you able to find a solution to this?  


Profile picture for user Sthong1221984

Sthong1221984  2 months 2 weeks ago

What happen after you brought your car in Autozone? Did they solve your concern?