I have an Ml 320 1998, the dash lights stopped working and the car wouldn’t start. I have tried all of the obvious usual; fuses, battery, starter motor etc. but nothing is a miss.

Has anyone had a similar problem or knows something to try I may of missed?

Thanks I really appreciate any help as I’m at a loss of what it is.

Comments

Surprisingly, this is not as uncommon of an issue as you might think.

I can see you have checked all the basics so let me point out a few more issues you must check.

1. A fault locking system - a fault can confuse the car into thinking it should not start. If there is an alarm system, try removing it

2. Did you check the ignition/started kit? those are very obvious places that can cause problems

3.The EIS and the fuel pump might also have an issue, did you look there?

4. Check all possible fuses, cause a small fuses can stop the whole car from starting

5. Did you use a scanner?

 

 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.