Hi, I was driving along and the dash display comes up with the following:

Display Fault

Speedtronic

SRS

All say go to workshop immediately. I've tried to diagnose the problem but it won't make a connection.

Checked all relays and fuses and the battery is ok.

Any advice would be much appreciated.

Comments

Profile picture for user Digga

Also the fuse for the diagnostic tool was in.

Profile picture for user Digga

I'm just waiting for my mate to get back to me with what brand. 

Profile picture for user Digga

brand of Diagnostic :

Autel Autolink AL 539b

Profile picture for user avinash12

Hi, I have experienced this kind of problem. what I generally come across is that there may be some water in the relay switch due to which I the sensors would have got damaged. i request you to clean it first and then get it inspected. 

Profile picture for user Digga

Thanks for the advice. I've been trying to see if there's a leak anywhere but can't find anything.

Profile picture for user avinash12

Hi if you didn't get any leakage then its a very good news. It will save lots of money. I would like to ask you that you should take out all the plugin in a systematic manner clean them and look for any wear and tear in the plugins and if you notice any sign of bur out you need to change it. If after doing this you didn't get your problem fix. just troubleshoot your sensors as per the guideline. that might fix the problem.

Profile picture for user MBFanatic

The scanner that you have is not able to read all systems on a Mercedes Benz. You either need a scanner that can read MB specfic systems such as SRS and instrument cluster or take it to a mechanic that has MB Star Diagnostic scanner.

Profile picture for user Digga

I think I’ll have to do that. Thanks for letting me know about the scanner your help is much appreciated 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

2010 Mercedes ML350 BlueTec fuel leak (Left tank)

0
tarheel3759
3 days ago
Mercedes » M-Class » 2006-2011

check liquid level

0
equintquant2
3 days ago
Mercedes » C-Class » 2001-2007

Mercedes Benz clk w208 supercharger

0
timcolledge
6 days ago
Mercedes » CLK-Class » 1998-2003

Dodge. Journey 2015

1
TennesseeRebel
6 days ago
Dodge » Journey » 2009-____

Is it my ignition switch?

0
lcserna0423
6 days ago
Dodge » Caravan » 2008-____

2009 Mercedes e350 rwd 80 k miles

2
lucapuca
1 week 1 day ago
Mercedes

2006 chrysler crossfire convertible top problem

2
daisyblemmons
1 week 4 days ago
Chrysler » Crossfire

Problem with automatic start

4
abchris
1 week 4 days ago
Audi » A3 S3 RS3 » 2015-____

Mercedes ML350 bluetec sputter misfire

1
Nmerc
1 week ago
Mercedes » M-Class » 2012-____

Fuel issue

1
Andrew Williams.90
1 week 1 day ago
Buick » LeSabre » 2000-2005

Brake system

2
tammyduran
1 week 4 days ago
BMW » Z4 » 2003-2008

Best Shocks for Grand Cherokee

2
JohnSmith75
1 week 5 days ago
Jeep » Grand Cherokee

W212 AMG seat swap

1
GPone
1 week 2 days ago
Mercedes

do you need to register new battery on 2006 z4???

1
jdgallo
1 week 2 days ago
BMW » Z4 » 2003-2008

Mercedes CLA 250

4
jc71
1 week 5 days ago
Mercedes

CHANGING DASHBOARD LANGUAGE

2
Master
1 week 3 days ago
Volvo » S40, V40

2004 f150 wont start

1
dldiggs2
1 week 6 days ago
Ford » F-Series » 2004-2008

2006 chrysler crossfire convertible top problem

1
daisyblemmons
1 week 4 days ago
Chrysler » Crossfire » 2004-2007

Intermittent issue with low cranking power when ESC OFF light comes on

1
SteveJ27
1 week 3 days ago
Hyundai » Elantra » 2007-2010

Apple car play for 2016 e350 4matic

2
Triangle123
1 week 3 days ago
Mercedes » E-Class » 2010-2016

User has not asked any questions.