Electrical problem

Dear all

My doughter has mb w204 c300 2011

Couple days first problem appear s when closing the drivers door the redio turns off and on again but yesterday she tried to turn it on but no start no egntion after taking the key out and try many times it's start but every single electricity in the car turns on and off  we tow it home but after that it's work fine as if nothing happens 

Comments

user profile image
Markthemechanic made a comment.
1 week 6 days ago

Are you trying to say that your Radio does not shut even when the car is switched off? This has personally happened to me and is actually a problem with a faulty radio system. It would be easy to blame some faulty circuits, but the radio system keeps on eating battery life even when the car is shut off.

 

How did I solve this problem? I did nothing, tried to switch on and off the ignition until the radio would shut off. I would suggest you don't take a risk like I did and replace the radio system with a new set. Otherwise, you will wake up one day with a very bad battery.

 
user profile image
MercedesMedic made a comment.
1 week 6 days ago

You need to get it scanned with star diagnostics. 

Most likely will be a defective SAM module. 

Let us know when you scan it and what codes come up. 

 
user profile image
marvin Best made a comment.
1 week 2 days ago

both front doors are not opening with the key FOB. What could be causing this?

 

Add new comment

The content of this field is kept private and will not be shown publicly.