hello every one i have mercedes W221 S500 model 2008 and there are misfiring in lift side in the four cylinders and i replaced all spark plugs and all ignition coils and disassembly the all engine to check the pistons and the valves ... etc and still there is misfire and i replaced air mass and the injectors and still there is misfire and replaced 3 engine control unit and still there is misfire in the same side and i replaced the o2 sensors and still there is miss fire in the same side

there is any one can help me

Comments

Oh wow!

To be honest, I have never heard of this happening to anyone.

I can see the car is 10 years old and these problems might occur, but were you ever in a bad accident?

From what it seems, the Engine is failing and it might be very bad news...

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.