I own a E300 W212, and i cant connect my phone with the cars bluetooth. In the screen it shows activating telephone and this thing goes on forever. I have tried to reset the nav system unit but that didnt help. Was wondering what would happen if i did the factory reset that is in the instrument cluster.

 

Comments

You can try to the IC reset but I doubt it will have any affect.

My suggestioin would be to try a different phone. There is a good chance the COMAND in your MB is not compatible with your cell phone.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.