2010 elantra touring w/ 5spd manual has hard time or can't crank engine over on occasions that

seem to immediately follow the times driven when the ESC OFF light has come on.

It's happened 5x in the last 2 months, 3 of which I had to boost or push start.

The light goes out and no issues starting the car for days up until the lights comes back on.

Battery is <6 months old.

Any info would really be great, thanks,

Steve.

 

Comments

As far as I can see, you have a faulty battery or a faulty connection with the battery.

 

I know your battery is less than 6 months old and you might feel like it can't go back.

But you can't rule our factory defects.

 

So yea, at works, its a factory defect and you need to change your battery. At best

it is just an issue with the circuit.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.