Is it the battery? If so, which one?

I have a 2010 S550 4matic. It has been slow starting for a while. I would have to push a second time for the car to actually start. I kept thinking I need to replace the battery but of course I pushed my luck. I got in a few days a go and it was turning over as if it was going to start but didn't. The more I tried, the less "noise" it made. Finally, it just clicked and then not even the dash lights would come on. After someone had jumper cables on the battery (under the hood) for a few, it started.

Please confirm that the battery under the hood is for starting the car. The auto part store told me the opposite. I have been told that the battery in the engine compartment is only for starting the car and the one in the trunk is for the electronics but the part store told me the exact opposite. Mercedes dealer is being their usual evasive selves because they want me to bring the car in. Can someone please clear this up once and for all? Many thanks in advance.


Ask a Question if you need help with your car.

Can you answer these questions?

HYUNDAI elantra EC
By inspjacktan 15 hours ago
Vehicle: Hyundai » Elantra » 2007-2010
3 series airbag light problems
By SETHB093 20 hours 52 minutes ago
Vehicle: BMW » 3-Series » 2004-2013
car start
By Tiger72 1 day 7 hours ago
Vehicle: Mercedes » E-Class » 1996-2003
Car accident report
By tiffanie89 1 day 8 hours ago
Vehicle: Hyundai » Sonata » 2006-2010
knocking sound when braking
By James Beyer 1 day 23 hours ago
Vehicle: Mercedes » E-Class » 2003-2009