without doing anything, just starting my car this morming and going out from my garage, 7 messages appeared on the dashboard :ABS not available, ESP not available, license plate right light not funct., license plate left light not func. 3rd stop light, rear light/rear fog light left. I checked all fuses, all ok. what's going wrong? need your help guys

Comments

That sounds like a battery issue. Also have you had any heavy rain? Do all the system work properly now? It has been a fewe days since you posted the question.

If all the systems are working properly now, I would check the battery. Replace it if it is over 5 years old.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.