Hello, I have problem with my autumatic transmission. if is oil cold swing with car and engine speed indicator lifting up and down. after he's warm everything is ok. makes it only if is cold Eben want more gas. Please any one any idea what is wrong?  I know that is problem in gearbox  but what exactly is wrong? Thank you :).

Comments

Profile picture for user MercedesMedic

Do you have any warning lights on? Check engine light?

My recommandation would be to read the codes and see if there is a fault code stored.

Are you saying the engine RPMs go up and down at startup? It wasn't clear to me.

Profile picture for user pajinuk

No, nothing warning light and any code on diagnostic. I will on the snap on  verus dio and nothing trouble code :-(.

if start car and drive  first five minute is everything ok after 5 min engine is stil cold temperature is on 50 maybe. If drive on the city relax speed  almost without gas  or want push gas pedal car start swing ( and this time of car swing,engine RPMs go up and down),but I  ride with this problem long time :-( so now is this problem little  bit bigger car no swing but kicking , when is engine oil hot around 80-90 temperature, car drive excellent.

 

sorry for my English, I still learn. And looking for right words. :)

Profile picture for user MercedesMedic

The reason why the problem may seem worse is that the engine mount may have failed. So first check the engine mounts. There is a test that you can perform yourself but will need a helper.

Just search this "bad motor mount youcanic"

I am thinking you may have a vacuum leak. At this point I am not convinced that this is a transmission problem. The TCU would have stored a code at this point.

Another posssiblity is bad mass air flow sensor.

Have you had a Mercedes expert look at it?

Profile picture for user pajinuk

Thank you, I will check all your ideas and give you know here. No nobody jet check just my friend but he isn’t is expert for Mercedes. Really expert on the automatic transmission told me 105£  + vat  only for. Testing :-(. So Iam now little bit frightened.

Profile picture for user pajinuk

Yes, I will tomorrow check mount engine and transmission.  Vacuum leak, and I will try clean maf air sensor, if will bad may I buy only sensor? Or must buy it all parts? For example 8et009149-421? Thank you

Profile picture for user pajinuk

Hello, so today I try engine mount test, others thinks I will do it later :).

but test show me that my left side engine mount is bad I think. If I try select R- reverse engine will ok last second on the video first is D  engine lift up and after R and engine stay. So wrong is only left side, I right?

Profile picture for user MercedesMedic

Your left side is completly shot. You should change them both. They gradually fail and the right one may have leaked of the oil but hasn't seperated yet.

Once you change them, you will think you got a brand new car.

Profile picture for user pajinuk

Thank you, I will do it I check first how see right side and if will little bit something wrong I changed both and one for transmission thank you if will done give know here. For now really big THANK YOU. 

We save me big money maybe :). 

Thank you

Profile picture for user pajinuk

Not yet, I don’t have time :-( we have here now snow complications :-).  If will fixed with this options I will inform here. 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Output Speed Sensor for 2011 Nissan Rogue

2
eantongiorgi@yahoo.com
4 months ago
Nissan » Rogue » 2008-2014

2010 Mercedes ML350 BlueTec fuel leak (Left tank)

0
tarheel3759
1 week 4 days ago
Mercedes » M-Class » 2006-2011

check liquid level

0
equintquant2
1 week 5 days ago
Mercedes » C-Class » 2001-2007

Mercedes Benz clk w208 supercharger

0
timcolledge
2 weeks ago
Mercedes » CLK-Class » 1998-2003

Dodge. Journey 2015

1
TennesseeRebel
2 weeks ago
Dodge » Journey » 2009-____

Is it my ignition switch?

0
lcserna0423
2 weeks 1 day ago
Dodge » Caravan » 2008-____

2009 Mercedes e350 rwd 80 k miles

2
lucapuca
2 weeks 4 days ago
Mercedes

2006 chrysler crossfire convertible top problem

2
daisyblemmons
2 weeks 6 days ago
Chrysler » Crossfire

Problem with automatic start

4
abchris
3 weeks ago
Audi » A3 S3 RS3 » 2015-____

Mercedes ML350 bluetec sputter misfire

1
Nmerc
2 weeks 2 days ago
Mercedes » M-Class » 2012-____

Fuel issue

1
Andrew Williams.90
2 weeks 4 days ago
Buick » LeSabre » 2000-2005

Brake system

2
tammyduran
2 weeks 6 days ago
BMW » Z4 » 2003-2008

Best Shocks for Grand Cherokee

2
JohnSmith75
3 weeks 1 day ago
Jeep » Grand Cherokee

W212 AMG seat swap

1
GPone
2 weeks 4 days ago
Mercedes

do you need to register new battery on 2006 z4???

1
jdgallo
2 weeks 4 days ago
BMW » Z4 » 2003-2008

Mercedes CLA 250

4
jc71
3 weeks ago
Mercedes

CHANGING DASHBOARD LANGUAGE

2
Master
2 weeks 6 days ago
Volvo » S40, V40

2004 f150 wont start

1
dldiggs2
3 weeks 1 day ago
Ford » F-Series » 2004-2008

2006 chrysler crossfire convertible top problem

1
daisyblemmons
2 weeks 6 days ago
Chrysler » Crossfire » 2004-2007

Intermittent issue with low cranking power when ESC OFF light comes on

1
SteveJ27
2 weeks 5 days ago
Hyundai » Elantra » 2007-2010

User has not asked any questions.