MB C200 2006 Transmission Problem

Hello.when I put the gear to the 1st gear and pressbgas pedal it knocks and change the gear very badly.and it also hast SRS error. Please help me out.
Thanks

Comments

user profile image
MercedesMedic made a comment.
1 year 4 months ago

SRS light is not related to your transmission problem.

If the car bangs when you put it in gear it could be two things.

First the valve body in the transmission.
Second it could be a motor mount.

Do you have the check engine light on?
Does the car shift normally in other gears?

 
user profile image
Moji827 made a comment.
1 year 4 months ago

Hello and Thanks for your response.
I didn’t mention that SRS light was related to transmission problems in fact the car has SRS error on its instrument cluster and in the meantime the transmission has some problems.My car doesn’t make any noice as I put it to D position instead as soon as I press the gas pedal (on D position,car stationary )the car shifts very badly without making any noise and also engine check light is on.
The car shifts normally in other gears

 
user profile image
MercedesMedic made a comment.
1 year 4 months ago

It could be a bad motor mount. Do you feed vibrations on your steering wheel or seat when you are stooped at a light?

 
user profile image
Moji827 made a comment.
1 year 4 months ago

No there are no such symptoms.the only thing felt is after pressing gas pedal.as I said before,as I press the throttle,it changes gear very badly and not smoothly(only very first gear)I mean from 2nd to 1st maybe Cos I heard,if true,this car starts from 2nd gear.

 
user profile image
Moji827 made a comment.
1 year 4 months ago

Mostly this happens when I take off from a light and it shifts hard one two and the rest firmer and normal.

 
user profile image
Moji827 made a comment.
1 year 4 months ago

Hi did you recieve my message?

 
user profile image
MercedesMedic made a comment.
1 year 4 months ago

Press the button that puts the transmission in winter mode. In this mode it always starts from second.

It is the S/W button or may also say C/W.

If it doesn't give you the same problems in W, there is an issue with the first gear. Solenoids or band for that gear can be bad.

 

Add new comment

The content of this field is kept private and will not be shown publicly.