seems the above is a relatively common issue. both batteries checked. rear all good, front aux replaced. still same issue. repalced voltage regulator on alternator. still same issue. comes on after 5 mins or so. goes off for 5 mins and then back - whats next logical step? BCM or Aux Relay?

Comments

You said that the batteries where checked. How did you check them? Also how old are the batteries?

Alexnzo1, 2019-03-08

Load test by auto electrician. Aux was replaced

I would check a couple of things. First make sure there is no loose contact at the battery terminals.

Second, I would still test the age of the main battery. It could be testing good, but that doesn't mean that it is providing enough juice for the power hungry Mercedes.

If it is none of these two, you need to connect a scanner and read the codes. Generic OBD2 scanner won't help and you need a scanner that can read Mercedes specific codes.

Let us know what you find out.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.