Question Details

 I have a Mercedes 2000 c280, stuck in the limp mode.  I replaced the conductor plate and the adapter sleeve.  I got codes p0715 and p0758. I then replaced the conductor plate and adapter sleeve again and all of the solenoids. I cleared the codes . It is still in the limp mode and the codes have reset and is showing p0715 and p0758.  I am at a loss.

Comments

Profile picture for user MercedesMedic

MercedesMedic  3 months 2 weeks ago

Sorry to hear about your troubles. When you look at the instrument cluster, next to the clock you should see the gear you are in. So you should see P, R, D as you move the shifter. Do you see any of these?


Profile picture for user wweaver157

wweaver157  3 months 2 weeks ago

No when it went into limp there is just a square blk.  I have 2nd & R.


Profile picture for user MercedesMedic

MercedesMedic  3 months 2 weeks ago

You need to replace the shifter module.


Profile picture for user MercedesMedic

MercedesMedic  3 months 2 weeks ago

Did you spill water on the shifter recently?

Your issue may not have been the valve body. But hey, replacing the conductor plate, adapter sleeve and doing a transmission flush doesn't hurt. :)


Profile picture for user wweaver157

wweaver157  3 months 2 weeks ago

no I haven't spilled any thing in the shifter.  how easy is it to replace and do I need to have any reprogramming afterward.


Profile picture for user wweaver157

wweaver157  3 months 2 weeks ago

also why would I get a p0715 or p0758 code,  you're probably right I was just wondering.  a real mech once told me that sometimes you have to put down your scanner and diagnose the problem. Thanks


Profile picture for user wweaver157

wweaver157  3 months 2 weeks ago

also why would I get a p0715 or p0758 code,  you're probably right I was just wondering.  a real mech once told me that sometimes you have to put down your scanner and diagnose the problem. Thanks


Profile picture for user MercedesMedic

MercedesMedic  3 months 2 weeks ago

No it does not need programing for that year. With that said, it would be good to read the old shifter and transfer to the new but regardless it should work.

Did you clear the codes from the transmission control unit? You need a scanner that will clear TCU codes. For that year you may need a scanner with the 38 pin connector.


Add new comment

The content of this field is kept private and will not be shown publicly.