MY C180 BENZ, MY ACCELERATOR PADDLE HAS MALFUNCTION,WHEN I START THE ENGINE,PUT I FEET ON THE ACCELATOR PADDLE SOMETHING IS HAPPENING IN TERMS OF MOVEMENT, THE CAR IS MOVING ON ITS ON, ADRINE, NO CHANGE OF SOUND AND ITS MOVING SLOWING LESS THAN 0.5KM OR LESS, I CANT SPEED MY CAR USING THE ACCELERATOR PADDLE?
KINDLY HELP

Comments

You need to read the codes via the OBD2 port. Ideally you need a Mercedes specific scanner but if that is no available a generic scanner may give you a hint.

My guess is the gas pedal itself is the issue. It has a potentiate that detects the position of the gas pedal. It can fail. Have had that happened in the past. Similar symptoms to yours.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.