Got a generic code P0730 it says module mod.. trying to figure out if that the problem why it wont shift in gear while im driving.

Comments

That's a generic code telling you there is a problem with the transmission. Your car has gone into safe limp mode. Most likely the problem is the valve body.

It could also be the 13 pin connector on the side of the transmission. Jack up the car. Disconnect the wire harness that goes to the transmission and check for oil leak. If there are leaks, clean the connector.

If that does not fix the problem, you will need a Mercedes specific scanner to read codes. My guess would be that the conductor plate on top of the valve body is the issue. If you have 5 speed transmission you can replace it with a used one.

If you have 7 speed transmission you can rebuild the one you have.

Let us know what you find out.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.