Mercedes C240 Still in Limp Mode after Several Repairs

Question by JoeJoe posted 8 months 1 week ago in Mercedes-Benz

For those who haven't been following; listed below is the history. I took this car to the dealer today and they ran the Star Diagnostics. The attachment is a scanned copy of the report that has the engine and transmission codes. There is a lot more to this report but I just scanned what I thought is pertinent. They told me I need a new conductor plate. I told them I already put in a new one and also solenoids. They then indicated I might need a new valve body. They told me they reset the codes.

When I left the car is doing exactly what it has done from the git go. Starts out in 1st, clunks into 2nd and stays there. The car never tries to shift into 3rd. I watched this on youtube:   maybe this is what I need to do.Appreciate all the help..joe

I was hoping for a hallelujah do you do moment but that didn't happen. No treat on Halloween for me. 

****for all of these issues listed below I reset the codes and checked the fluid lever after the car warmed up. My scanner is a Ancel FX2000.

I don't know if this matters but after I completed all the things listed below; there was no difference in anything. It responded exactly as if I didn't do anything.

1. There were no previous issues with the transmission prior to this event. I was driving in 2nd gear on the interstate and floored it to get into traffic and it went into limp mode as soon as it downshifted into 1st.

2. Replace conductor plate and female 13 prong adapter - cleaned all components with electrical contact cleaner - did not fix problem / Drove it several times and still the same. Start out in 1st shifts to 2nd won’t shift into 3rd and won’t downshift to 1st. Stuck in second gear.

3. Checked TCU under floorboard for oil - no oil clean / The shifter seems to be ok. Nothing unusual about the way it works and the correct gear it is in is displayed on the instrument panel.

4. Replaced Mass Air Sensor

5. Because of the following reading of 0 on the "shift pressure control solenoid valve", I bought new solenoids and replaced them. I checked the new solenoids to make sure they worked. I also checked the solenoids I removed and they worked too but I went ahead and installed the new ones.

Set current of component Y3/6y2 (Shift pressure control solenoid valve)   986 mA

Actual current of component Y3/6y2 (shift pressure control solenoid valve)  980 mA

Pressure of component Y3/6y2 (shift pressure control solenoid valve)     0 mbar

6, Put everything back together and still the same. The reading on the data stream for the "shift pressure control solenoid valve" still read 0

I don't know what to do next.