OK so, I had an issue with my battery running flat, in the end it wouldn't hold a charge so I bought a new one.
Before I bought a new one I started getting problems and hoped this would sort things out.
I'd say every 1 out of 3 starts I get a barrage of faults appear and the car won't come out of park.
I get ABC (active body control), ESP and BAS (brake Assist) and distronic faults, on top of this the indicators stop working, the auto headlights stop working among other non essential bits.
Some times it works fine and there are no faults.
Alot of the fault codes point to something called a N73 module and refure to the CAN

Any help would be appreciated because I'm absolutely lost

Thanks

Comments

I think you may have multiple issues. Start with the n73 first wich is the ignition module. It's failing. See if you can find a company that repairs them. Can't use an old one.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.