Mercedes E4 30 transmission making loud whining noise and losing power I once had an issue where my radiator busted I was overheating and all of a sudden transmission fluid leak. Transmission lost power. I didn’t run it to cause any damage. I had the radiator replaced and it fixed The transmission leak. Then the replacement radiator somehow had a problem and begin to leak so now I am in a situation where I can’t afford to replace it just yet. But then all of a sudden  my transmission starts to slip a little then loses power now he makes a whining whining sound and loses power but there is no fluid leaking. I’ve done a little research but I’m not a mechanic but I understand what it could be. Does anyone have any advice . I always tell my friends I’m driving a Mercedes but I’m not rolling a Mercedes there is a difference. I can’t really afford repairs right now. Please help! Anyone?

Comments

Profile picture for user MercedesMedic

Hi there,

I am very sorry to hear about your transmission problem. This is what could have happened. The transmission got damaged and the transmission and coolant started to mix. They are part of the same radiator but have separate chambers. When that happens coolant makes into the transmission. If that does happen, it is the end of the transmission. I have seen that happened before.

You don't have to believe me. What you should do is to drop the trans oil pan, and inspect the bottom of the pan. If what I am assuming is correct, the clutch material will be on the bottom of the oil pan. It clogs the filter and then you get the whine and no movement because no transmission oil circulates.

Does your car start to drive if you let it parked for a few hours? 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

2010 Mercedes ML350 BlueTec fuel leak (Left tank)

0
tarheel3759
3 days ago
Mercedes » M-Class » 2006-2011

check liquid level

0
equintquant2
3 days ago
Mercedes » C-Class » 2001-2007

Mercedes Benz clk w208 supercharger

0
timcolledge
6 days ago
Mercedes » CLK-Class » 1998-2003

Dodge. Journey 2015

1
TennesseeRebel
6 days ago
Dodge » Journey » 2009-____

Is it my ignition switch?

0
lcserna0423
6 days ago
Dodge » Caravan » 2008-____

2009 Mercedes e350 rwd 80 k miles

2
lucapuca
1 week 1 day ago
Mercedes

2006 chrysler crossfire convertible top problem

2
daisyblemmons
1 week 4 days ago
Chrysler » Crossfire

Problem with automatic start

4
abchris
1 week 4 days ago
Audi » A3 S3 RS3 » 2015-____

Mercedes ML350 bluetec sputter misfire

1
Nmerc
1 week ago
Mercedes » M-Class » 2012-____

Fuel issue

1
Andrew Williams.90
1 week 1 day ago
Buick » LeSabre » 2000-2005

Brake system

2
tammyduran
1 week 4 days ago
BMW » Z4 » 2003-2008

Best Shocks for Grand Cherokee

2
JohnSmith75
1 week 5 days ago
Jeep » Grand Cherokee

W212 AMG seat swap

1
GPone
1 week 2 days ago
Mercedes

do you need to register new battery on 2006 z4???

1
jdgallo
1 week 2 days ago
BMW » Z4 » 2003-2008

Mercedes CLA 250

4
jc71
1 week 5 days ago
Mercedes

CHANGING DASHBOARD LANGUAGE

2
Master
1 week 3 days ago
Volvo » S40, V40

2004 f150 wont start

1
dldiggs2
1 week 6 days ago
Ford » F-Series » 2004-2008

2006 chrysler crossfire convertible top problem

1
daisyblemmons
1 week 4 days ago
Chrysler » Crossfire » 2004-2007

Intermittent issue with low cranking power when ESC OFF light comes on

1
SteveJ27
1 week 3 days ago
Hyundai » Elantra » 2007-2010

Apple car play for 2016 e350 4matic

2
Triangle123
1 week 3 days ago
Mercedes » E-Class » 2010-2016

User has not asked any questions.