Question Details

 Mercedes E4 30 transmission making loud whining noise and losing power I once had an issue where my radiator busted I was overheating and all of a sudden transmission fluid leak. Transmission lost power. I didn’t run it to cause any damage. I had the radiator replaced and it fixed The transmission leak. Then the replacement radiator somehow had a problem and begin to leak so now I am in a situation where I can’t afford to replace it just yet. But then all of a sudden  my transmission starts to slip a little then loses power now he makes a whining whining sound and loses power but there is no fluid leaking. I’ve done a little research but I’m not a mechanic but I understand what it could be. Does anyone have any advice . I always tell my friends I’m driving a Mercedes but I’m not rolling a Mercedes there is a difference. I can’t really afford repairs right now. Please help! Anyone?

Comments

Profile picture for user MercedesMedic

MercedesMedic  11 months ago

Hi there,

I am very sorry to hear about your transmission problem. This is what could have happened. The transmission got damaged and the transmission and coolant started to mix. They are part of the same radiator but have separate chambers. When that happens coolant makes into the transmission. If that does happen, it is the end of the transmission. I have seen that happened before.

You don't have to believe me. What you should do is to drop the trans oil pan, and inspect the bottom of the pan. If what I am assuming is correct, the clutch material will be on the bottom of the oil pan. It clogs the filter and then you get the whine and no movement because no transmission oil circulates.

Does your car start to drive if you let it parked for a few hours? 


Add new comment

The content of this field is kept private and will not be shown publicly.