About couple of months back my E55 didn't start. I called AAA to tow. Before help arrived after 15 mts I tried and was able to start the engine. AAA guy came and tried and it started without any problem. I was using the car without any issues. About 10 days back again it didn't start and called AAA. AAA person came and car started without any problem. He did a battery test and it passed. Now engine starts without any issue and I don't know, when it will give trouble. Engine never fails during the drive.
One more observation-After this problem, engine light comes and it goes away after driving 10 mts. Could you please let me know what will be the problem?
Thanks
/Sridhar

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.