Hi guys, today my heaters & a.c. have stopped working out of the blue. I noticed yesterday that when I opened the car, the heaters were blowing but without the key in the ignition. Any ideas what is the issue with it? I'm not sure if it's an electrical fault as my back right hand break light stays on constantly, when the bulb is connected. I've only had the car a couple of months & still under warranty from the private garage I brought it from.

Comments

That problem may be caused by a defective Signal Acquisition Module. Have the garage scan the codes from the heating and AC control unit. 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.