I have 2006 Mercedes E-500 4matic.
My air suspension is not working.
Message that appears is STOP CAR TO LOW. Compressor works. No fuse is blown, replaced both K67 relays. Also replaced the manifold with valves. Still car won’t raise. There is no leaks either. Also I have disconnected the battery for 20 minutes as a last resort. Yet car won’t rise. Has anybody any tips on this issue?
Thank you.

Comments

It is possible that the compressor works but it is not generating enough pressure. Have had that happened in the past. 

That would be my first guess. 

 

The problem is that you need Star Diagnostic or a Level 3 OBD2 scanner to diagnose this problem. 

 

That will allow you to test generated pressure. 

How long it takes for the air compressor to generate pressure. 

Check for leaks. 

 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.