I have a Mercedes E550 w212 2009 and I bought a 10 inch screen system Android and worked all the functions but there is no sound and when the factory screen is also not sound

Comments

MB uses optical lines to connect the various components. If one of them is taken out, such as the head unit, there will be no sounds.

 

Check with the seller to see if they have solution for your car.

I removed it and installed it again but the audio did not work and also when I reinstalled the OEM screen the audio did not work either

I removed it and installed it again but the audio did not work and also when I reinstalled the OEM screen the audio did not work either

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.