Dealer instructed to replace steering angle sensor(since they could not communicate with the sensor) then have vehicle aligned and then calibrate replacement sensor. Did that and drove about 10 miles to get home when BAS/ESP light came on again. Asked owner/mechanic to reset light. He did and said he saw a code for a "lateral" sensor(but he did not think it influenced the existing problem). He also stated that if the light came on again-there was nothing more he could do to help.  Any ideas to correct this problem.

Comments

Lateral sensor could be the problem. Especially if the code was for that sensor.

 

Also what is the code in the Abs esp module  

Thank you.  Original MB printout indicated  steering angle sensor codes:C1140-006/007/011 and ESP lateral acceleration sensor code C1142.

You had two problems and you only fixed one. The lateral sensor is also an issue that needs to be fixed. 

It could be the sensor or the wiring to it. 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.