The car battery drained overnight  for my ML350 2012 BT and i had to recharge it. Since then the Command centre does not turn on anymore; I can't use navigate, audio, rear camera, nothing at all. please can you advise how to reset the command centre or do I need to take it to repair centre?

Sammy

Comments

Hey Sammy

 

Hopefully this might be a simple issue with the fuse.

 

If you check in the rear fuse box, no. 25, you should be able to see if the fuse of your command centre. Check to make sure if it is okay or has it gone bad. If the fuse is bad, you can simply replace it and your command centre should work fine!

 

If not, I'm afraid you might need to change it.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.