My Service engine light is on I replaced my ignition coils twice it will not pass emissions, the code P 1320 keeps coming up 

Comments

Make sure the wires are connected in the the right order. If they are not you will get the error you describe. 

 

Nissans are very sensitive to aftermarket ignition coils.

Check the wires first. Make sure they are not swapped.

Once you verify the wires, swap one of the  OEM coils with the aftermarket one. If the code moves with the aftermarket coil, you found your problem.

If not, you have a wire harness problem or bad ECM.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.