To whom it may concern    

       I’m having issues after I changed the speed sensor from my 2015 Nissan Sentra. At first it was coding p0750 and now it’s coding p0846 and my car doesn’t speed up after running a few minutes. At first it runs fine then it’s not speeding up after I make a stop. Can you help me figure out what the heck it’s going on with my car 

Comments

You should replace the transmission fluid pressure sensor. Based on the code and your symptoms it is defective. If the sensor sends no data when it warms up then the transmission control unit will not allow you to shift to prevent the transmission. 

It should be difficult to find out what the problem is. If we go deeper, the fault code P0846 is ''Transmission Fluid Pressure Sensor / Switch B Circuit Range Performance''

 

So that is where you should look. There is definately can issue with the circuit

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.