I have a 2000 lincoln continental and initially a transmission overheat message came on so I stopped for a while and everything seemed to be good..fluid level and no leaks. Started it back up and it was gone. It did this again couple days later but also check engine light came on and p1744 code is what it is reading. So I have done a coolant flush and chamged trans filter and fluid..but not in torque converter. After that it seemed to be fine..the code even went away..for a couple days..now it is back on and the message on my dash says check transmission..what do I do or where do I go from here..this message comes on randomly sometimes often and sometimes not but when it does the car shifts hard again in the first couple years and it also will sort of slip out of gear going down the road as if it slipped to neutral..I mean no power in gas pedal for a sec but the thing is that the rpms drop badly while it does this..my guess is limp mode maybe..Idk..i am maybe thinking its the torque converter clutch solenoid..Idk amd its frustrating..someone please help.

Comments

Profile picture for user MercedesMedic

Do you thing the problem is happening when you are on fourth gear?

The problem here would most likely be the torque converter clutch solenoid or the valve body. There could be a mechanical damage to the transmission clutch packs as well.

I assume you have made sure the trans fluid is correct becasue that can be a cause as well.

At this point, you can try getting a good scanner that can read transmission codes. That may give you a better idea of what is worng.

Or take it to the dealer for a diagnostics and see what they got to say.

 

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

2010 Mercedes ML350 BlueTec fuel leak (Left tank)

0
tarheel3759
1 week 4 days ago
Mercedes » M-Class » 2006-2011

check liquid level

0
equintquant2
1 week 4 days ago
Mercedes » C-Class » 2001-2007

Mercedes Benz clk w208 supercharger

0
timcolledge
2 weeks ago
Mercedes » CLK-Class » 1998-2003

Dodge. Journey 2015

1
TennesseeRebel
2 weeks ago
Dodge » Journey » 2009-____

Is it my ignition switch?

0
lcserna0423
2 weeks ago
Dodge » Caravan » 2008-____

2009 Mercedes e350 rwd 80 k miles

2
lucapuca
2 weeks 3 days ago
Mercedes

2006 chrysler crossfire convertible top problem

2
daisyblemmons
2 weeks 6 days ago
Chrysler » Crossfire

Problem with automatic start

4
abchris
2 weeks 6 days ago
Audi » A3 S3 RS3 » 2015-____

Mercedes ML350 bluetec sputter misfire

1
Nmerc
2 weeks 1 day ago
Mercedes » M-Class » 2012-____

Fuel issue

1
Andrew Williams.90
2 weeks 3 days ago
Buick » LeSabre » 2000-2005

Brake system

2
tammyduran
2 weeks 5 days ago
BMW » Z4 » 2003-2008

Best Shocks for Grand Cherokee

2
JohnSmith75
3 weeks ago
Jeep » Grand Cherokee

W212 AMG seat swap

1
GPone
2 weeks 4 days ago
Mercedes

do you need to register new battery on 2006 z4???

1
jdgallo
2 weeks 4 days ago
BMW » Z4 » 2003-2008

Mercedes CLA 250

4
jc71
3 weeks ago
Mercedes

CHANGING DASHBOARD LANGUAGE

2
Master
2 weeks 5 days ago
Volvo » S40, V40

2004 f150 wont start

1
dldiggs2
3 weeks 1 day ago
Ford » F-Series » 2004-2008

2006 chrysler crossfire convertible top problem

1
daisyblemmons
2 weeks 6 days ago
Chrysler » Crossfire » 2004-2007

Intermittent issue with low cranking power when ESC OFF light comes on

1
SteveJ27
2 weeks 4 days ago
Hyundai » Elantra » 2007-2010

Apple car play for 2016 e350 4matic

2
Triangle123
2 weeks 5 days ago
Mercedes » E-Class » 2010-2016

User has not asked any questions.