I have recently purchased an OEM Android Auto unit from China for my ML 350 W166 2013. On connecting it everything works well except the reverse camera video. I have the original MB camera still connected. It powers up and shows the reverse guide lines but there is no pic when i engage reverse. The vendor says i must buy a camera from him to have that function but i think there's one more step to make the reverse camera work since it's already powered without changing or drilling holes to add an OEM camera. Just need the video signal to show.

 

Any help or suggested wiring to complete the setup

Comments

Profile picture for user kincsem

Hey mate

 

Was the unit you purchased from China branded or with some kind of warranty? I've had a couple of my friends go through similar experiences.

 

I think, the vendor is correct in this case to be honest. They are up selling but that is the way they make money. You might not get a video signal since there is no output at all.

 

My recommendation is to not play around with your current unit and buy the camera from the vendor. It should work.

Profile picture for user samoratrustmlingwa

I bought the unit in China. I guess i have to order the camera from the vendor. Thought i could find a solution on here

Profile picture for user MercedesMedic

I would check under setting to see if there anything that will allow you to configure the video input.

Also did the unit you installed have a seprate input for video? Check the owners manual it should something something.

The other isssue here may be the head unit is not turning on the camera because it is not realizing the car is in Reverse gear.

Let us know what else you find out.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

2010 Mercedes ML350 BlueTec fuel leak (Left tank)

0
tarheel3759
3 days ago
Mercedes » M-Class » 2006-2011

check liquid level

0
equintquant2
3 days ago
Mercedes » C-Class » 2001-2007

Mercedes Benz clk w208 supercharger

0
timcolledge
6 days ago
Mercedes » CLK-Class » 1998-2003

Dodge. Journey 2015

1
TennesseeRebel
6 days ago
Dodge » Journey » 2009-____

Is it my ignition switch?

0
lcserna0423
6 days ago
Dodge » Caravan » 2008-____

2009 Mercedes e350 rwd 80 k miles

2
lucapuca
1 week 1 day ago
Mercedes

2006 chrysler crossfire convertible top problem

2
daisyblemmons
1 week 4 days ago
Chrysler » Crossfire

Problem with automatic start

4
abchris
1 week 4 days ago
Audi » A3 S3 RS3 » 2015-____

Mercedes ML350 bluetec sputter misfire

1
Nmerc
1 week ago
Mercedes » M-Class » 2012-____

Fuel issue

1
Andrew Williams.90
1 week 1 day ago
Buick » LeSabre » 2000-2005

Brake system

2
tammyduran
1 week 4 days ago
BMW » Z4 » 2003-2008

Best Shocks for Grand Cherokee

2
JohnSmith75
1 week 5 days ago
Jeep » Grand Cherokee

W212 AMG seat swap

1
GPone
1 week 2 days ago
Mercedes

do you need to register new battery on 2006 z4???

1
jdgallo
1 week 2 days ago
BMW » Z4 » 2003-2008

Mercedes CLA 250

4
jc71
1 week 5 days ago
Mercedes

CHANGING DASHBOARD LANGUAGE

2
Master
1 week 3 days ago
Volvo » S40, V40

2004 f150 wont start

1
dldiggs2
1 week 6 days ago
Ford » F-Series » 2004-2008

2006 chrysler crossfire convertible top problem

1
daisyblemmons
1 week 4 days ago
Chrysler » Crossfire » 2004-2007

Intermittent issue with low cranking power when ESC OFF light comes on

1
SteveJ27
1 week 3 days ago
Hyundai » Elantra » 2007-2010

Apple car play for 2016 e350 4matic

2
Triangle123
1 week 3 days ago
Mercedes » E-Class » 2010-2016

User has not asked any questions.