Hi All

I picked up a 2003 G500. It drove fine upon putting it on delivery truck. Once arrived it would not shift into D. Stuck in P until used screwdriver to stick down in gear shift override mech. Once in D will not shift gears (limp mode). Also PRND indicator still shows it in P no matter if shifted into R or D. Ive read a lot of post of one occurring but not usually both situations together.Help?

 

Comments

That is strange as typically you will have both missing PRND and limp mode. But my guess is that you have a defective shiffter module.

The best way to know if to hook it up to MB Star Diagnostic and find out what the codes are. Or you can read them yourself if you have the right scanner.

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.