Hi. I have a 2005 645ci . My transmission gears get stuck in 2 gear and will not drive. I tried unplugging the battery and waiting 15 to 30ty minutes and some times it will reset and sometimes it won’t. I put it in the shop and they said it was a fuse and a broken wire after paying $840.00 getting it back after 4 days it started doing it again. Please help me 

Comments

Profile picture for user Markthemechanic

Wow, $840?!

 

Okay, so I am assuming this is a stick transmission which is giving you a lot of problems.

 

If a 'broken fuse' did not solve the issue. I guess the problem might be deeper. Did they use a scanner? Did you see the issue.

 

I am assuming that if the car is a bit old, maybe the whole transmission module might need to be changed.

 

Did you also go to an authorized dealer? cause you need to make sure they actually Fixed the issue, if you know what I mean

Profile picture for user MercedesMedic

Sorry to hear about your troubles.

You need to get the codes from the tranmission module. Also check what codes where there before. If they are the same, the mechanic didn't fix anything.

Profile picture for user Walt1095

Connection linesI know he didn’t and I told him it’s doing the same thing so he came up to my job and put another fuse in and gave me two fuses if it goes out again. I have the transmission that has both auto and stick. I ask what is causing the fuse to blow and he said it was the wire that he charge but looking at it it doesn’t look like a wire was change because the are all on Connection lines . Wouldn’t you have to change the whole connection peace 

Profile picture for user Walt1095

do you know what the problem could be that is making it blow a fuse and getting stuck in gear

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

2010 Mercedes ML350 BlueTec fuel leak (Left tank)

0
tarheel3759
6 days 20 hours ago
Mercedes » M-Class » 2006-2011

check liquid level

0
equintquant2
6 days 21 hours ago
Mercedes » C-Class » 2001-2007

Mercedes Benz clk w208 supercharger

0
timcolledge
1 week 2 days ago
Mercedes » CLK-Class » 1998-2003

Dodge. Journey 2015

1
TennesseeRebel
1 week 2 days ago
Dodge » Journey » 2009-____

Is it my ignition switch?

0
lcserna0423
1 week 2 days ago
Dodge » Caravan » 2008-____

2009 Mercedes e350 rwd 80 k miles

2
lucapuca
1 week 5 days ago
Mercedes

2006 chrysler crossfire convertible top problem

2
daisyblemmons
2 weeks 1 day ago
Chrysler » Crossfire

Problem with automatic start

4
abchris
2 weeks 1 day ago
Audi » A3 S3 RS3 » 2015-____

Mercedes ML350 bluetec sputter misfire

1
Nmerc
1 week 4 days ago
Mercedes » M-Class » 2012-____

Fuel issue

1
Andrew Williams.90
1 week 5 days ago
Buick » LeSabre » 2000-2005

Brake system

2
tammyduran
2 weeks 1 day ago
BMW » Z4 » 2003-2008

Best Shocks for Grand Cherokee

2
JohnSmith75
2 weeks 2 days ago
Jeep » Grand Cherokee

W212 AMG seat swap

1
GPone
1 week 6 days ago
Mercedes

do you need to register new battery on 2006 z4???

1
jdgallo
1 week 6 days ago
BMW » Z4 » 2003-2008

Mercedes CLA 250

4
jc71
2 weeks 2 days ago
Mercedes

CHANGING DASHBOARD LANGUAGE

2
Master
2 weeks ago
Volvo » S40, V40

2004 f150 wont start

1
dldiggs2
2 weeks 3 days ago
Ford » F-Series » 2004-2008

2006 chrysler crossfire convertible top problem

1
daisyblemmons
2 weeks 1 day ago
Chrysler » Crossfire » 2004-2007

Intermittent issue with low cranking power when ESC OFF light comes on

1
SteveJ27
2 weeks ago
Hyundai » Elantra » 2007-2010

Apple car play for 2016 e350 4matic

2
Triangle123
2 weeks ago
Mercedes » E-Class » 2010-2016

User has not asked any questions.