Question Details

Hello im raul my question is whether my engine or my transmission is gone im a tell you the symptons First is when i step on the gas to go it hesitates and takes a longer time to shift to 2nd so when 2nd kicks in it goes ok and the rpm goes almost to the end until let go of gas and step on it instantly and it goes into 3rd and it drags it again til i hit 70 and it goes from there ok no shaking from the engine but i just want my car back to almost normal and 2 altanators went bad in 2 weeks

Comments

Profile picture for user MBFanatic

MBFanatic  1 year 5 months ago

Two alternator bad in two weeks. That's not normal. Is the check engine light on? Have you checked the codes?


Profile picture for user Raul E Rivas

Raul E Rivas  1 year 4 months ago

I checked the codes i have 4 of them p0171 p0410 p0562 p0238 i know one means one of my senors was bad fixed that one meant the battery sucked i got a new one and one of them means i got a leak in one of the vaccuum hoses or my intake im not sure and the supercharger one i dont know i just got money to take it to the shop is there anythng ii can do to fix my car before it goes all wrong


Profile picture for user Juan God'sson Rosado

Juan God'sson Rosado  1 year 5 months ago

Sounds like a transmission slipping


Profile picture for user Raul E Rivas

Raul E Rivas  1 year 4 months ago

How do know for aure its my transmission


Profile picture for user MBFanatic

MBFanatic  5 months 3 weeks ago

Did you get the problem fixed?