Trying to see if my engine is still good or if its my transmission going bad

Hello im raul my question is whether my engine or my transmission is gone im a tell you the symptons First is when i step on the gas to go it hesitates and takes a longer time to shift to 2nd so when 2nd kicks in it goes ok and the rpm goes almost to the end until let go of gas and step on it instantly and it goes into 3rd and it drags it again til i hit 70 and it goes from there ok no shaking from the engine but i just want my car back to almost normal and 2 altanators went bad in 2 weeks

Comments

user profile image
MBFanatic made a comment.
1 year 8 months ago

Two alternator bad in two weeks. That's not normal. Is the check engine light on? Have you checked the codes?

 
user profile image
Raul E Rivas made a comment.
1 year 7 months ago

I checked the codes i have 4 of them p0171 p0410 p0562 p0238 i know one means one of my senors was bad fixed that one meant the battery sucked i got a new one and one of them means i got a leak in one of the vaccuum hoses or my intake im not sure and the supercharger one i dont know i just got money to take it to the shop is there anythng ii can do to fix my car before it goes all wrong

 
user profile image
Juan God'sson Rosado made a comment.
1 year 8 months ago

Sounds like a transmission slipping

 
user profile image
Raul E Rivas made a comment.
1 year 7 months ago

How do know for aure its my transmission

 
user profile image
MBFanatic made a comment.
9 months ago

Did you get the problem fixed? 

 

Add new comment

The content of this field is kept private and will not be shown publicly.