Question Details

Hi,

i have benz w220 2003 get flooded and found rear sam damage, replaced and now comand not working, and srs alarm activated, front light left side low beam not working, and right turn signal and foglight not working

any advice and help,

my battery before dead and now voltage before starting 12.1 to 12.5V now car used only few hours over one month because the issues

please refer to my post bellow the scan of fault before light issue comes up

https://mbworld.org/forums/s-class-w220/725356-s500-2003-flooded-not-start-comand-suspension-issue.html#post7608519

Comments

Profile picture for user MercedesMedic

MercedesMedic  2 months 4 weeks ago

Don't worry about the SRS light. At least not yet. You need to fix the audio system then try clearing the SRS light. A failed audio system will trigger the airbag light. I have seen this many times.

The other thing is that you may have a defective cluster and also a bad audio gateway module located in the trunk.

Can you post the code pictures here? They tend to get lost over time in car forums.


Profile picture for user sayedbaqer

sayedbaqer  2 months 4 weeks ago

could you guide me to solve the issues,

i try to upload the photo but only able to upload one,

i open the comand into parts and reassembly, also rear audio gateway i open it and i see board looks great

now the comand issue and front lighting as well srs

i try many thing but still not success

please guide


Profile picture for user Sthong1221984

Sthong1221984  2 months 4 weeks ago

Have you tried to check all wiring connectors and module because it submerge with flood water. Maybe some connectors and modules develop corrosion particles because of the flood make sure to clean properly.


Profile picture for user sayedbaqer

sayedbaqer  2 months 4 weeks ago

This module i open before it have fiber optic in and out one coming from looks comand and out go to another module which the first one found rusty and second one fine, light come in first module but nothing out

Fiber


Profile picture for user sayedbaqer

sayedbaqer  2 months 4 weeks ago

I bypass the previous module and comand working with sound fine only voice control found disable, cd changer fine as well, 

yesterday as well hazard continue flashing i research and. Suggest to replace siren so i remove and no more hazard flashing, but now srs and front ligths issue

Car internal open


Profile picture for user MBFanatic

MBFanatic  2 months 4 weeks ago

Is your radio working properly now?? Still getting sound from speakers? 

Also can you rescan and post the codes?? 


Profile picture for user abusufyan

abusufyan  2 months 4 weeks ago

Has your issue been resolved?


Profile picture for user sayedbaqer

sayedbaqer  2 months 4 weeks ago

Radio working fine, sound ok every thing looks fine,

Now srs and front light issue still, as last scan show one light module fail


Profile picture for user Sthong1221984

Sthong1221984  2 months 4 weeks ago

It's better to replace light module then re scan. Flooded unit make you costly because it submerge to flood water and you need to do step by step to determine the extend damage cause by water. And depends on how long and deep the car stay in flooded water. 


Profile picture for user sayedbaqer

sayedbaqer  2 months 4 weeks ago

I just go through the scan result i found alarm with part number 2208602585 i research it looks like srs issue related, and front light 2208203885 module failure but that one successful reset by Star scanner? 

 


Profile picture for user sayedbaqer

sayedbaqer  2 months 3 weeks ago

I exchange the ballast between front light, it is same left side xenon not working and left side turn light not working i check the turn light i found it is still healthy 


Profile picture for user MBFanatic

MBFanatic  2 months 3 weeks ago

You still have a bad SAM. Can you please post the codes that have Present status? 


Profile picture for user sayedbaqer

sayedbaqer  2 months 3 weeks ago

I have to take it to shop to allow him to scan,


Profile picture for user MBFanatic

MBFanatic  2 months 3 weeks ago

Get carsoft 7.4 multiplexer and scan it yourself. A lot cheaper than going to the shop every time. This requires a laptop.

 

Another option is icarsoft mb ii scanner. 


Profile picture for user sayedbaqer

sayedbaqer  2 months 3 weeks ago

I check front right side same, i disassembled it I didn’t see any sign of damage, if you could go through the list of photo that i post, and guide me if possible to check before rescan again


Profile picture for user MBFanatic

MBFanatic  2 months 3 weeks ago

You can't spot water damage that easily. Especially if it didn't stay in the module didn't get too wet. Reading codes or doing a full scan is your next step  


Profile picture for user MBFanatic

MBFanatic  2 months 3 weeks ago

You can't spot water damage that easily. Especially if it didn't stay in the module didn't get too wet. Reading codes or doing a full scan is your next step  


Profile picture for user sayedbaqer

sayedbaqer  2 months 3 weeks ago

I have test front light xenon, i exchange ballast, and bulb and bulb unit same right side xenon working and left not, while fog light on right not working and left working similarly turn light left working and right not


Profile picture for user sayedbaqer

sayedbaqer  2 months 3 weeks ago

The problem that time i scan but all what i got from scan was useless until i go and do bypass on the module that i have mentioned before 


Profile picture for user sayedbaqer

sayedbaqer  2 months 3 weeks ago

After troubleshooting and research i found this

https://w220.ee/SAM_(Signal_Acquisition_/_Actuation_Module)

where they mention the right SAM responsible for full right light

except low beam on right and left low beam controled by right sam I conclude the issue with right SAM and i open i found one cable lose fixed light fine now only the issue remains with srs alarm

any help


Profile picture for user MBFanatic

MBFanatic  2 months 3 weeks ago

That's great news. Now try to get the fault codes for the SRS. 


Profile picture for user sayedbaqer

sayedbaqer  2 months 2 weeks ago

I have scan the system and alot of fsult present reset, and now fine, srs as well alarm reset, i try to remove right seat one by one srs cables, alarm comes, reconnected, again i reset i am not sure if it is good way to test functionality of srs system, only air bag i reset i dont have any idea to test

Profile picture for user sayedbaqer

sayedbaqer  2 months 2 weeks ago

Fault


Profile picture for user sayedbaqer

sayedbaqer  2 months 2 weeks ago

Fault 2


Profile picture for user MercedesMedic

MercedesMedic  2 months 2 weeks ago

All these codes are stored. Try clearing them. Let us know if any of them come back after clearing. 


Profile picture for user sayedbaqer

sayedbaqer  2 months 2 weeks ago

Thanks bro, I already cleared,

i scan again after doing clear for the codes,

nothing come back 


Profile picture for user abusufyan

abusufyan  2 months 1 week ago

wow I have happy that this complicated mystery is solved. Please keep posting your questions and allow us to serve you.