Question Details

Hi, i recently changed the transmission oil and all shifting solenoids in my 722.9 box after it just started slipping,

filled the transmission with the right red oil from benz, about 9 litres and dropped the excess amount at 45C degree.

after the oil change the car drove normal for a week, after a week the box started to cut out while driving as if it goes into neutral and then back in gear. the next morning it would not go, when you put it in gear, it rolls with no power, just enough to roll on flat ground (same with reverse), if you hit the accelerator the engine revs but the car does not move. i suspected the transmission pump because the transmission has no energy in it, but i am doubting it because there is no noising coming when i rev the engine. i am scanning it with Autel Maxicom MK808 scanner, no faults are showing for the tranny. what could it be?

thanks

Comments

Profile picture for user BMWadict

BMWadict  2 months ago

Seems like a low transmission fluid case or problem with the trans oil pump. Unless the transmission oil filter has gotten loose. Did you check the transmission fluid level again?


Profile picture for user eagerman

eagerman  1 month 4 weeks ago

Hi Mate, thanks for your reply, i will jack the car soon and check the oil level and filter if it is loose to rule them out. was busy finishing my degree and left the car standing for couple of months. thanks for your advice

Profile picture for user abusufyan

abusufyan  1 month 4 weeks ago

we are glade that you found this website helping for you. Will be eagerly waiting to hear from you after you get it oil level checked.

and congrats for completing your degree.


Add new comment

The content of this field is kept private and will not be shown publicly.