Neither of the high beams on the 2016 Hyundai Elantra will work. The switch seams to be in working order and the light on the dash (that indicates that the bright lights are activated) also works when the switch is activated. The high beam bulbs test good. Is there a fuse somewhere that controls the high beams? There isn't any reference on either fuse box (under the dash or hood) that tells me that it is for the high beams. Is there another location for the fuse? Is it paired on another fuse and just not listed? Please let me know. Thank you.

Comments

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.