I just replaced the HVAC blower motor on 1992 Mercedes 300D. As you know, the monopost wiper has to be removed in order to remove the blower from its perch.

While I had the wiper assembly out of the car, I decided to re-grease the gears following instructions I found online. I even marked the position of the arms relative to the bolts. Everything is installed and the blower works, even on auto! However, my wiper won’t park properly. Any suggestions?

Comments

Can you remove the arm and reinstall it rotated slightly to correct the problem?

Plain text

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type='1 A I'> <li> <dl> <dt> <dd> <h2 id='jump-*'> <h3 id> <h4 id> <h5 id> <h6 id>
  • No HTML tags allowed.
  • Lines and paragraphs break automatically.
  • Only images hosted on this site may be used in <img> tags.
The content of this field is kept private and will not be shown publicly.

Disclaimer: Youcanic has made every effort to assure the accuracy of the information on this page. Neither Youcanic nor its affiliates assume responsibility for any loss or damage due to any errors, omissions, lack of information. You agree to hold Youcanic free from any liability arising out of the use of any information contained within. All pictures and references to trademarks and car names are for reference only and do not imply an association with the manufacturer. Consult your owner's manual or authorized factory manuals when performing repair procedures. By entering this site, you agree to our Terms & Conditions and Privacy Polity.